Forum update

Official announcements about ARGUS TV
lisag
Posts: 50
Joined: Fri Jun 06, 2014 4:43 pm

Re: Forum update

Post by lisag » Tue Oct 03, 2017 2:13 pm

Hi, I've donated, can I have access to the new releases please?

I'll be happy to participate in the testing processes and feedback any issues.

thanks.

rbarthen7
Posts: 6
Joined: Wed Oct 04, 2017 2:00 am

Re: Forum update

Post by rbarthen7 » Wed Oct 04, 2017 2:27 am

Argus TV is the best scheduler I've used. However, I can't use it because of tuner compatibility. I have a couple Hauppauge DualHD USB tuners and another generic tuner that crash the Argus Recorder service. I'm definitely interested in tuner compatibility updates. I would be happy to donate if I knew there would be updates to at least add compatibility for the DualHD tuner. It's not clear to me that new tuners will be added. I reviewed the source on GitHub, but I couldn't identify the code for loading and using the tuners. Maybe that part isn't opensource. If new tuner compatibility is being added, count me in for a donation, testing, and potentially contributions to the code .

Infidelus
Posts: 464
Joined: Wed May 28, 2008 7:53 pm
Location: UK

Re: Forum update

Post by Infidelus » Wed Oct 04, 2017 10:30 am

I've been using a Hauppauge DualHD tuner with Argus TV for quite some time now and haven't had any tuner crashes.

I have had them on the TBS card I also have though as their drivers are pretty poor.

I've actually just bought a second DualHD for precisely that reason.

rbarthen7
Posts: 6
Joined: Wed Oct 04, 2017 2:00 am

Re: Forum update

Post by rbarthen7 » Wed Oct 04, 2017 8:04 pm

That's interesting that you are having success with the dualHD tuner. I tried it on 2 different machines and had the same issue. I'm using the latest driver Version 34210. I wonder if you're having success with an older driver. I may look for an older driver if that's the case.

User avatar
dot-i
Site Admin
Posts: 5848
Joined: Mon Oct 01, 2012 3:40 pm

Re: Forum update

Post by dot-i » Wed Oct 04, 2017 10:14 pm

lisag wrote:
Tue Oct 03, 2017 2:13 pm
Hi, I've donated, can I have access to the new releases please?

I'll be happy to participate in the testing processes and feedback any issues.
Thank you, and fixed!!
I have the heart of a child. I keep it in a jar on my shelf. -- Robert Bloch
Image

Infidelus
Posts: 464
Joined: Wed May 28, 2008 7:53 pm
Location: UK

Re: Forum update

Post by Infidelus » Thu Oct 05, 2017 10:46 am

rbarthen7 wrote:
Wed Oct 04, 2017 8:04 pm
That's interesting that you are having success with the dualHD tuner. I tried it on 2 different machines and had the same issue. I'm using the latest driver Version 34210. I wonder if you're having success with an older driver. I may look for an older driver if that's the case.
I've just checked, and I'm using version 34035, so yes, it's an older release. Maybe I won't bother upgrading it :)

rbarthen7
Posts: 6
Joined: Wed Oct 04, 2017 2:00 am

Re: Forum update

Post by rbarthen7 » Fri Oct 06, 2017 3:43 am

Infidelus wrote:
Thu Oct 05, 2017 10:46 am
rbarthen7 wrote:
Wed Oct 04, 2017 8:04 pm
That's interesting that you are having success with the dualHD tuner. I tried it on 2 different machines and had the same issue. I'm using the latest driver Version 34210. I wonder if you're having success with an older driver. I may look for an older driver if that's the case.
I've just checked, and I'm using version 34035, so yes, it's an older release. Maybe I won't bother upgrading it :)
Thanks for your comments. I tried driver version 34035 and it couldn't match the drivers to my device. After further review, I found that there are 2 models of the dualHD. My model is 1595 and there is another model 1590. It looks like 1595 is more common in the USA and 1590 appears to be more common in the UK. I suspect the compatibility issue relates to the model rather than the driver. I think I may be at a dead end unless the compatibility can be addressed. If anyone is interested, the error message that I get is "Unable to find input pin
at ArgusTV.Recorder.Bda.BdaUtility.ConnectFilterPins...".

rudig
Posts: 251
Joined: Tue Sep 06, 2011 6:21 pm

Re: Forum update

Post by rudig » Fri Oct 06, 2017 8:29 am

Wild guess, but did you setup in "recorder console" menu "cards" the input type per card?
Mine (totally different card btw) is set to automatic, could it be that argus has an issue determining how to configure the card?

Infidelus
Posts: 464
Joined: Wed May 28, 2008 7:53 pm
Location: UK

Re: Forum update

Post by Infidelus » Fri Oct 06, 2017 10:06 am

rbarthen7 wrote:
Fri Oct 06, 2017 3:43 am
After further review, I found that there are 2 models of the dualHD. My model is 1595 and there is another model 1590. It looks like 1595 is more common in the USA and 1590 appears to be more common in the UK. I suspect the compatibility issue relates to the model rather than the driver.
You're right, there are two models and I am indeed using the 1590 version. Not something I'd considered when replying, so you may well be correct in your assumption.

rbarthen7
Posts: 6
Joined: Wed Oct 04, 2017 2:00 am

Re: Forum update

Post by rbarthen7 » Sun Oct 08, 2017 9:21 am

Infidelus wrote:
Fri Oct 06, 2017 10:06 am
rbarthen7 wrote:
Fri Oct 06, 2017 3:43 am
After further review, I found that there are 2 models of the dualHD. My model is 1595 and there is another model 1590. It looks like 1595 is more common in the USA and 1590 appears to be more common in the UK. I suspect the compatibility issue relates to the model rather than the driver.
You're right, there are two models and I am indeed using the 1590 version. Not something I'd considered when replying, so you may well be correct in your assumption.
I was able to debug ArgusTV.Recorder.Bda.dll and I discovered that it was returning 4 ATSC devices for my dualHD. The first 2 devices were the actual tuners and the last 2 caused the invalid input pin error because they were null devices. I was able to patch the dll so that it would skip over the null devices and my 1595 version of the dualHD no longer crashes the recorder service. The tuners now appear in the recorder client and I'm able to view TV. So far things look promising. Even though I solved the issue myself, I know I will benefit from Argus and I have left a donation. Hopefully dot-i can update the library or will share the code so others may benefit.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest