Page 4 of 7

Re: Forum update

Posted: Tue Oct 03, 2017 2:13 pm
by lisag
Hi, I've donated, can I have access to the new releases please?

I'll be happy to participate in the testing processes and feedback any issues.

thanks.

Re: Forum update

Posted: Wed Oct 04, 2017 2:27 am
by rbarthen7
Argus TV is the best scheduler I've used. However, I can't use it because of tuner compatibility. I have a couple Hauppauge DualHD USB tuners and another generic tuner that crash the Argus Recorder service. I'm definitely interested in tuner compatibility updates. I would be happy to donate if I knew there would be updates to at least add compatibility for the DualHD tuner. It's not clear to me that new tuners will be added. I reviewed the source on GitHub, but I couldn't identify the code for loading and using the tuners. Maybe that part isn't opensource. If new tuner compatibility is being added, count me in for a donation, testing, and potentially contributions to the code .

Re: Forum update

Posted: Wed Oct 04, 2017 10:30 am
by Infidelus
I've been using a Hauppauge DualHD tuner with Argus TV for quite some time now and haven't had any tuner crashes.

I have had them on the TBS card I also have though as their drivers are pretty poor.

I've actually just bought a second DualHD for precisely that reason.

Re: Forum update

Posted: Wed Oct 04, 2017 8:04 pm
by rbarthen7
That's interesting that you are having success with the dualHD tuner. I tried it on 2 different machines and had the same issue. I'm using the latest driver Version 34210. I wonder if you're having success with an older driver. I may look for an older driver if that's the case.

Re: Forum update

Posted: Wed Oct 04, 2017 10:14 pm
by dot-i
lisag wrote:
Tue Oct 03, 2017 2:13 pm
Hi, I've donated, can I have access to the new releases please?

I'll be happy to participate in the testing processes and feedback any issues.
Thank you, and fixed!!

Re: Forum update

Posted: Thu Oct 05, 2017 10:46 am
by Infidelus
rbarthen7 wrote:
Wed Oct 04, 2017 8:04 pm
That's interesting that you are having success with the dualHD tuner. I tried it on 2 different machines and had the same issue. I'm using the latest driver Version 34210. I wonder if you're having success with an older driver. I may look for an older driver if that's the case.
I've just checked, and I'm using version 34035, so yes, it's an older release. Maybe I won't bother upgrading it :)

Re: Forum update

Posted: Fri Oct 06, 2017 3:43 am
by rbarthen7
Infidelus wrote:
Thu Oct 05, 2017 10:46 am
rbarthen7 wrote:
Wed Oct 04, 2017 8:04 pm
That's interesting that you are having success with the dualHD tuner. I tried it on 2 different machines and had the same issue. I'm using the latest driver Version 34210. I wonder if you're having success with an older driver. I may look for an older driver if that's the case.
I've just checked, and I'm using version 34035, so yes, it's an older release. Maybe I won't bother upgrading it :)
Thanks for your comments. I tried driver version 34035 and it couldn't match the drivers to my device. After further review, I found that there are 2 models of the dualHD. My model is 1595 and there is another model 1590. It looks like 1595 is more common in the USA and 1590 appears to be more common in the UK. I suspect the compatibility issue relates to the model rather than the driver. I think I may be at a dead end unless the compatibility can be addressed. If anyone is interested, the error message that I get is "Unable to find input pin
at ArgusTV.Recorder.Bda.BdaUtility.ConnectFilterPins...".

Re: Forum update

Posted: Fri Oct 06, 2017 8:29 am
by rudig
Wild guess, but did you setup in "recorder console" menu "cards" the input type per card?
Mine (totally different card btw) is set to automatic, could it be that argus has an issue determining how to configure the card?

Re: Forum update

Posted: Fri Oct 06, 2017 10:06 am
by Infidelus
rbarthen7 wrote:
Fri Oct 06, 2017 3:43 am
After further review, I found that there are 2 models of the dualHD. My model is 1595 and there is another model 1590. It looks like 1595 is more common in the USA and 1590 appears to be more common in the UK. I suspect the compatibility issue relates to the model rather than the driver.
You're right, there are two models and I am indeed using the 1590 version. Not something I'd considered when replying, so you may well be correct in your assumption.

Re: Forum update

Posted: Sun Oct 08, 2017 9:21 am
by rbarthen7
Infidelus wrote:
Fri Oct 06, 2017 10:06 am
rbarthen7 wrote:
Fri Oct 06, 2017 3:43 am
After further review, I found that there are 2 models of the dualHD. My model is 1595 and there is another model 1590. It looks like 1595 is more common in the USA and 1590 appears to be more common in the UK. I suspect the compatibility issue relates to the model rather than the driver.
You're right, there are two models and I am indeed using the 1590 version. Not something I'd considered when replying, so you may well be correct in your assumption.
I was able to debug ArgusTV.Recorder.Bda.dll and I discovered that it was returning 4 ATSC devices for my dualHD. The first 2 devices were the actual tuners and the last 2 caused the invalid input pin error because they were null devices. I was able to patch the dll so that it would skip over the null devices and my 1595 version of the dualHD no longer crashes the recorder service. The tuners now appear in the recorder client and I'm able to view TV. So far things look promising. Even though I solved the issue myself, I know I will benefit from Argus and I have left a donation. Hopefully dot-i can update the library or will share the code so others may benefit.