Argus-TV 2.3 RC Helpers Thread

Installing and setting up ARGUS TV
Posts: 4
Joined: Mon Oct 20, 2014 2:48 pm

Re: Argus-TV 2.3 RC Helpers Thread

Post by phate89 » Mon Oct 20, 2014 7:17 pm

Hi. I installed today for the first time aargus and i started with 2.3 RC. I configured everything and it works but i couldn't add new scheduled recordings from scheduler console (in web interface was working). I got this error in the log:

Code: Select all

[Error][20]: REST POST /Scheduler/UpcomingProgramsForSchedule
System.FormatException: Stringa non riconosciuta come valore DateTime valido.
   in System.DateTime.ParseExact(String s, String[] formats, IFormatProvider provider, DateTimeStyles style)
   in ArgusTV.DataContracts.ScheduleExtensions.ToRule(SerializableRule from)
   in ArgusTV.DataContracts.ScheduleExtensions.<>c__DisplayClass8.<ToSchedule>b__6(SerializableRule r)
   in System.Collections.Generic.List`1.ForEach(Action`1 action)
   in ArgusTV.DataContracts.ScheduleExtensions.ToSchedule(SerializableSchedule serializableSchedule)
   in ArgusTV.ServiceImplementation.SchedulerModule.<.ctor>b__d8(Object p)
   in CallSite.Target(Closure , CallSite , Func`2 , Object )
   in Nancy.Routing.Route.<>c__DisplayClass4.<Wrap>b__3(Object parameters, CancellationToken context)
So i went in my format settings (my windows use italian defaults) and changed from and to HH:mm:ss.
After this change i was able to add scheduled recordings but i still get this error when i try to edit an already added one (and it doesn't work even in web interface)

Posts: 9
Joined: Tue Oct 07, 2014 6:07 pm

Re: AW: Argus-TV 2.3 RC Helpers Thread

Post by pünktchen » Wed Oct 29, 2014 2:49 am

pünktchen wrote:@dot-i
Would you please update your code on github with MP1.9?!
I've tried the client code of MP1.7 with references to MP1.9 - compiling has worked, but in MediaPortal itself
nothing is shown in the guide etc...
Sorry for qouting myself, but @dot-i would you please update the wip-branch!

Posts: 1
Joined: Thu Nov 13, 2014 2:57 am

Re: Argus-TV 2.3 RC Helpers Thread

Post by TheFonz » Thu Nov 13, 2014 3:24 am


Updated Argus TV to 2.3 RC and am having a couple of issues:

1. When testing the shares I get the error that they are not OK.
2. When I look at the recorders in the Schedulers Console I see this: Name: ARGUS | Service URL: http://localhost:49953/ArgusTV/Recorder. If I ping the server it works, if I test the shares I get an error the server was no contactable.
3. When I try and live stream a channel from the TV Scheduler Console I get the error Unable to start live streaming.

Any help getting Argus back working would be appreciated.


//EDIT:: I resolved all these issues by uninstalling and reinstalling. I only made 1 change and that was to select advanced settings and choose a local admin Username & Password for the shares.

Posts: 18
Joined: Sun Aug 09, 2015 9:48 am

Re: Notifier not connecting to scheduler

Post by nmw01223 » Sun Aug 09, 2015 9:56 am

dl144 wrote:After installing 2.3 RC the tray notifier icon was always showing "Not connected to core services" ...

... To fix this, right click on the notifier icon, select options and fill in the user name and password boxes.
I found the same on 2.3 (8/4/2015), but would add one extra bit of information: I found that if one right clicks on the icon as started up on login (windows 7), a context menu with 'Options ...' comes up, but so does an hourglass and you can get no further.

However, having killed the notifier process in task manager, if it is restarted from the Start Menu entry, no such problem occurs, you can click 'Options ...' and set the user account / password to that you created on installation.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest