ArgusTVRecorder service no longer starting

In the unlikely ;) event you encounter a bug, tell us here
Post Reply
wernerk
Posts: 39
Joined: Mon May 05, 2014 9:21 pm

ArgusTVRecorder service no longer starting

Post by wernerk » Sun Aug 05, 2018 9:56 am

After having no problems for quite some while, the recorder service started to shutting itself down after a few seconds, showing error "The process cannot access the file because it is being used by another process".

Any idea on how to find out which file is the culprit? or a hint on how to solve that?
thx and br werner

Code: Select all

2018-08-05 09:49:27.3668 [Info ][ARGUS TV Recorder]: ARGUS TV Recorder 2.3 main-thread started.
2018-08-05 09:49:27.3968 [Info ][ARGUS TV Recorder]: Starting service.
2018-08-05 09:49:27.6801 [Info ][ARGUS TV Recorder]: Starting service hosts.
2018-08-05 09:49:32.9301 [Error][ARGUS TV Recorder]: System.Net.HttpListenerException (0x80004005): The process cannot access the file because it is being used by another process
   at System.Net.HttpListener.AddAllPrefixes()
   at System.Net.HttpListener.Start()
   at Nancy.Hosting.Self.NancyHost.TryStartListener()
   at Nancy.Hosting.Self.NancyHost.StartListener()
   at Nancy.Hosting.Self.NancyHost.Start()
   at ArgusTV.Recorder.MainThread.Initialize(Boolean systemResuming)
   at ArgusTV.Recorder.MainThread.Run()
2018-08-05 09:49:33.1864 [Info ][ARGUS TV Recorder]: Stopping service.

wernerk
Posts: 39
Joined: Mon May 05, 2014 9:21 pm

Re: ArgusTVRecorder service no longer starting

Post by wernerk » Sun Aug 05, 2018 10:10 am

tried to re-install 2.3 completely. still the same problem...

User avatar
JMS
Posts: 47
Joined: Fri May 30, 2008 12:23 am
Location: Königswinter, NRW, Germany
Contact:

Re: ArgusTVRecorder service no longer starting

Post by JMS » Mon Aug 06, 2018 8:18 pm

On first sight it looks like a conflict on TCP Ports. On which ports is the service configured to connect? You may use tools like https://docs.microsoft.com/en-us/sysint ... ds/tcpview to see if any other application is using the port - maybe some game server or whatever. Although HttpListener allows different applications to share a port this only works if each application is configured to so.

Jochen

wernerk
Posts: 39
Joined: Mon May 05, 2014 9:21 pm

Re: ArgusTVRecorder service no longer starting

Post by wernerk » Mon Aug 20, 2018 2:29 pm

hi, your tip about looking at tcp ports kind of kindled the right idea.
obviously one of my programs manipulated the "hosts" file with a new entry for 127.0.0.1
seems that this was the culprit since after de-installation/reg-cleanup und changing the hosts file back to normal, argus-tv scheduler is starting again! and recorder can connect again!
thx and br werner

wernerk
Posts: 39
Joined: Mon May 05, 2014 9:21 pm

Re: ArgusTVRecorder service no longer starting

Post by wernerk » Sun Nov 18, 2018 10:39 am

ok. just for info to anyone who needs it... :)

it happened again to me.
so after a bit of additional research i found that windows-servers are using portrange 49152 - 65535 for "RPC randomly allocated high TCP ports".

see e.g.
https://support.microsoft.com/en-us/hel ... or-windows

so, guess it was about starting-order, timing of all windows-services during startup, and a bit of luck, that made it work... or not.

after checking availability of ports (using tool CurrPorts from Nirsoft), i changed all argustv ports in all config-files i found from 499xxx to 479xxx. and this solved the issue for me... for now :)

cheers werner

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest