ARGUS-TV 2.01 ...frequent thumbnails generated with 0bytes.

In the unlikely ;) event you encounter a bug, tell us here
User avatar
Hominidae
Posts: 361
Joined: Wed Feb 01, 2012 10:45 pm

ARGUS-TV 2.01 ...frequent thumbnails generated with 0bytes.

Post by Hominidae » Mon Feb 18, 2013 10:34 pm

...subject says it all.
I've been seeing loads of these after moving over from 4TR 1.7.
I remember this problem is known from 4TR but only for some HD content and I am seeing this more often now.
According to v2.01 release notes, thumbnail creation should have improved..I feel it is quite the opposite.

...any hints on how to debug?

User avatar
dot-i
Site Admin
Posts: 5848
Joined: Mon Oct 01, 2012 3:40 pm

Re: ARGUS-TV 2.01 ...frequent thumbnails generated with 0byt

Post by dot-i » Mon Feb 18, 2013 11:09 pm

ezThumb was updated and usually it should indeed give better results, but alas it seems there are exceptions :(

Perhaps we can send a short sample of a ts file that fails to generate a thumb to the author?
I have the heart of a child. I keep it in a jar on my shelf. -- Robert Bloch
Image

User avatar
Hominidae
Posts: 361
Joined: Wed Feb 01, 2012 10:45 pm

Re: ARGUS-TV 2.01 ...frequent thumbnails generated with 0byt

Post by Hominidae » Mon Feb 18, 2013 11:18 pm

....we sure could try an arrange for samples, but I have the feeling that the root cause is somewhere else.
When deleting the 0-bytes thumbs, usually the thumbs will appear/be (re-)created fine after a short length of time.

User avatar
Hominidae
Posts: 361
Joined: Wed Feb 01, 2012 10:45 pm

Re: ARGUS-TV 2.01 ...frequent thumbnails generated with 0byt

Post by Hominidae » Tue Feb 19, 2013 3:29 pm

...OK, I can reconfirm.
Just deleted some of the 0-bytes thmb-files last night.
This morning, the thmbs are all there...fresh and fine.
The only thing/difference I can think of is, that in between my postprocessing with comskip had finshed.
The .ts were not cut/altered, but now the .edl file sits there as well.

..does ezThumb acknowledge/make use of that file?
Does comskip run interfere with ezThumb (are both programs "fighting" to access the file?)?

..when the next 0-bytes thumbs are available, I'll destroy the edl file as well to see if that makes any difference.

User avatar
Sjakko
Posts: 561
Joined: Fri Jan 23, 2009 2:05 pm
Location: Netherlands

Re: ARGUS-TV 2.01 ...frequent thumbnails generated with 0byt

Post by Sjakko » Tue Feb 19, 2013 10:37 pm

Hominidae wrote:Does comskip run interfere with ezThumb (are both programs "fighting" to access the file?)?
A manual test shows that if comskip is running, ezthumb can't access the recording file with a "file not found" error. Using Sysinternals Process Monitor I found that this is indeed what happens: ARGUS TV calls ezthumb when the comskip postprocessing task is still running.

What I can't explain is why it creates a 0byte thumbnail file on your system. In my tests simply no thumbnail file is created in this situation

A possible solution: ask dot-i to let ARGUS TV run ezthumb and wait for it to exit before running any postprocessing tasks.
ARGUS TV + Recorder, 4 x FloppyDTV DVB-C, Smargo Smartreader Plus, MDAPI Plus, ACamd, OSCam, Win7 x64.

User avatar
Hominidae
Posts: 361
Joined: Wed Feb 01, 2012 10:45 pm

Re: ARGUS-TV 2.01 ...frequent thumbnails generated with 0byt

Post by Hominidae » Wed Feb 20, 2013 12:44 pm

Oh, wow!
Thanks for doing these tests.
I actually never checked creation/last-accessed times on the files.

The comskip .logo.txt file indicates, that postprocessng starts as soon as .ts is closed (after recording)
The comskip .edl file indicates when comskip finished
For the 0bytes files, I have no clue...they were just evidence for me that something is wrong.
Based on what you describe, I looked into my folders and found other thumbs, that were created while comskip
was still running, but that are larger than 0bytes but still crippled (way too small).
Using Sysinternals Process Monitor I found that this is indeed what happens: ARGUS TV calls ezthumb when the comskip postprocessing task is still running.
I found these two examples which make me think that some intellingence is already build in
and that your general rule is not in place.

Sammple-A: Here the thumbnail gets created while comskip still active -> thumb is crippled

Image

Sample-B: Here the thumbnail was created after comskip had finished...everything is fine.

Image

So, what is failing in ARGUS within the synchronisation of these two concurrent tasks after recording ends?

User avatar
Hominidae
Posts: 361
Joined: Wed Feb 01, 2012 10:45 pm

Re: ARGUS-TV 2.01 ...frequent thumbnails generated with 0byt

Post by Hominidae » Wed Feb 20, 2013 12:50 pm

Sjakko wrote: A possible solution: ask dot-i to let ARGUS TV run ezthumb and wait for it to exit before running any postprocessing tasks.
I'd say I'd rather have it the other way round...run ezTumb only after postprocessing has ended.
This will create a thumb with correct content, should the .ts have been altered during postprocessing (like comercials were cut, not only marked)

User avatar
Hominidae
Posts: 361
Joined: Wed Feb 01, 2012 10:45 pm

Re: ARGUS-TV 2.01 ...frequent thumbnails generated with 0byt

Post by Hominidae » Mon Feb 25, 2013 8:11 pm

Here's one with 0-bytes.
Again, ezThumb process was started while comskip post-processing was still active.

Image

User avatar
dot-i
Site Admin
Posts: 5848
Joined: Mon Oct 01, 2012 3:40 pm

Re: ARGUS-TV 2.01 ...frequent thumbnails generated with 0byt

Post by dot-i » Tue Feb 26, 2013 8:42 pm

Hominidae wrote:I'd say I'd rather have it the other way round...run ezTumb only after postprocessing has ended.
This will create a thumb with correct content, should the .ts have been altered during postprocessing (like comercials were cut, not only marked)
Depends... Post-processing can even be run at night, and it runs asynchronously, so it's not quite that straightforward to postpone running ezThumb.

It's really too bad comskip doesn't play "nice" and allow the thumbnailer to read the file while it's working...
I have the heart of a child. I keep it in a jar on my shelf. -- Robert Bloch
Image

User avatar
Hominidae
Posts: 361
Joined: Wed Feb 01, 2012 10:45 pm

Re: ARGUS-TV 2.01 ...frequent thumbnails generated with 0byt

Post by Hominidae » Wed Feb 27, 2013 12:32 am

dot-i wrote:It's really too bad comskip doesn't play "nice" and allow the thumbnailer to read the file while it's working...
Hmm...I am no developer for windoze based applications, but AFAIR there are several modes to open a file.
Is it comskip that doesn't play nice or is it ezThumb asking for more rights than required for the job?

However I'll file a pointer over in the comskip forum....at least another chance to cure the symptom.

Strange thing is, I see the effect only in large numbers since I moved from 4TR to ARGUS....

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest