Page 1 of 1

Detected Cards issue, existing card lost and newly detected

Posted: Sun Aug 11, 2013 12:12 pm
by ChrisRichner
I'm using an AsRock Vision 3D with two USB Pinnacle PCTV Quatro Stick 510e. Cards look like this

Tuner|Detected|USB Tuner
1 | Yes | 1
2 | Yes | 2

Suddenly after a fewing working resumes from hibernation the recording service says that one of the two USB tuner is not detected, instead it's listing the same tuner with a new number.

Tuner | Detected | USB Tuner
1 | Yes | 1
2 | No | 2
3 | Yes | 2

If this happens the scheduler service cancels all "upcoming programs" and no further tv shows are recorded, in fact the recording service functionality is completely broken.

The windows device manager says everything is ok with the usb tuners.

Question 1: How can I fix this mess?
Question 2: Why does the scheduler service completely stop recording when just one of two cards fail? Why is not using the card that still works?

Help gladly appreciated

Re: Detected Cards issue, existing card lost and newly detec

Posted: Sun Aug 11, 2013 3:12 pm
by Hominidae
...just an arrow into the blue, but it might look like your USB devices get renumbered each time.
Is there something like "USB hotplug" that can be disabled or enabled in the settings?

What you want is, that the System would keep the devices recognized .
Also, does this happen with only one card connected?
Might be, that two of the same model get assigned the same ID or using the same scheme and depending on how fast they wakeup, the system just mixes internal IDs.

Re: Detected Cards issue, existing card lost and newly detec

Posted: Sun Sep 01, 2013 10:19 pm
by ChrisRichner
Thank you for your answer, I've managed to overcome this issue by attaching both cards to usb 2.0 slots instead of splitting them on usb 3.0 and 2.0. I've also changed the timing by starting the services automatic delayed giving the system more time to boot up before argus uses the tuner cards.

Re: Detected Cards issue, existing card lost and newly detec

Posted: Fri Sep 27, 2013 7:21 pm
by dot-i
Great you got it solved, it does indeed sound like Windows was sort of reshuffling your sticks -- confusing the ARGUS TV Recorder in the process.

Re: Detected Cards issue, existing card lost and newly detec

Posted: Thu Oct 03, 2013 6:48 pm
by ChrisRichner
Hi

I'm running without any issues since a few weeks now.. but why does the scheduler service completely stop recording when just one of two cards fail? Why is not using the card that still works?

I would assume that the service uses the tuners available and skip the undetected.

viewtopic.php?f=52&t=4223

Code: Select all

 System.ServiceModel.AddressAlreadyInUseException: There is already a listener on IP endpoint 0.0.0.0:49942. This could happen if there is another application already listening on this endpoint or if you have multiple service endpoints in your service host with the same IP endpoint but with incompatible binding configurations. ---> System.Net.Sockets.SocketException: Only one usage of each socket address (protocol/network address/port) is normally permitted
Any clues?

Re: Detected Cards issue, existing card lost and newly detec

Posted: Wed Dec 11, 2013 11:12 am
by maysider
dot-i wrote:Great you got it solved, it does indeed sound like Windows was sort of reshuffling your sticks -- confusing the ARGUS TV Recorder in the process.
is possible to cope the problem inside the Argus TV server app somehow?

Re: Detected Cards issue, existing card lost and newly detec

Posted: Wed Mar 09, 2016 4:06 pm
by axlt2002
Hi All,

Just to notify that I'm facing the same issue described in the first post.

The weird thing is that I have a dual-tuner TV card connected to a PCI port (so is not an issue of prioritization in the device mapping or similar havign two distinct cards on different ports).

I have also configured both ARGUS TV Services to be started with a delay...but the issue still remains. Please note that this is not systmatic but it happens, I would say, "randomly" and apparently without any specific reason.

Can someone kindly provide some guidance?

Thanks in advance!