Issues with ongoing (live) recordings and skip forward

Access your ARGUS TV system from your sofa using Kodi or XBMC (http://kodi.tv/)
Post Reply
johan2626
Posts: 2
Joined: Sun Dec 02, 2012 1:25 pm
Location: Belgium

Issues with ongoing (live) recordings and skip forward

Post by johan2626 » Sun Mar 10, 2013 7:15 pm

I have a strange problem and I am wondering whether other people have seen this happening before? The problem is that when I am looking at a recording that is still ongoing, when I want to skip forward (30 secs) after eg. looking 10 minutes at the recording from the start XBMC/Argus plugin does not skip forward at all. Instead it jumps backwards in time an no matter how many times you skip forward you keep going back to the same moment in time.


The way how to reproduce this is:
1) Record a program in HD (HD is probably not relevant anyway, but this is how I am using it)
2) After 5 minutes recording - play the recording from the start
3) After 6 minutes of playing; press skip forward 30 secs
Now I notice that I am put back to 4:05 of the recording and cannot go forward whatever times I press skip forward.

The only way to really skip eg a commercial in this case - is to restart the recording from 0 again and then skip forward to the place you wanted to be (yes - then you can actually use skip forward). After looking a while however the problem is repeated.

I do not know whether this problem is related to ArgusTV or not, so starting here. I do notice some errors in the logfile I uploaded.

http://pastebin.com/pTr5Q37V

Some background info
1) recording was started @ 15:57
2) playback started @ 16:02
3) skip forward was pressed a couple of times around 16:08

This is a very annoying problem - family doesn't like the multiple times you have to restart a live recording to skip commercials...

I will later try this on a Mac or PC as well to rule out OS. Note that I have seen this on XBMCbuntu as well... My Argus setup is working fine and did not miss a recording yet.

Hope we can resolve this.

Tx
johan
Backend windows 7 PC with ArgusTV 2.0.1 - 2x Digital Devices DuoFlex S2 (4 tuners); frontend 1x Zotac ID41 with XBMC Openelec 2.99.4; 1x Raspberry Pi with XBMC Openelec 2.99.4

cncb
Posts: 49
Joined: Sun Nov 13, 2011 12:31 am

Re: Issues with ongoing (live) recordings and skip forward

Post by cncb » Wed Nov 06, 2013 9:34 pm

I notice the same behavior with OpenElec 3.2.3 and Argus 2.1. Is there any way to fix this or is it a limitation of XBMC (I don't see this behavior in MediaPortal)?

cncb
Posts: 49
Joined: Sun Nov 13, 2011 12:31 am

Re: Issues with ongoing (live) recordings and skip forward

Post by cncb » Tue Dec 03, 2013 12:28 am

Is there any possibility that this could be fixed? Or does it happen to be fixed in Gotham? Thanks.

Red_F
Posts: 533
Joined: Wed May 19, 2010 10:31 pm
Location: The Netherlands

Re: Issues with ongoing (live) recordings and skip forward

Post by Red_F » Thu Jan 02, 2014 11:45 pm

I am not too sure about watching a program that is still being recorded.

I'm using it myself every now and then, but only on programs that have no commercials (although I need to skip the first 10 minutes or so since I start my recordings 10 minutes early). And that seems to work fine.

Perhaps XBMC is having difficulties realising the length of the file is actually changing. Or XBMC is trying to skip beyond the end of the current recorded file.

When you are viewing a recording, the addon is only used initially to retrieve the filename of the recording. After that XBMC uses its standard player to play the file. So if there is a problem while viewing a recording there is not much I can do in the addon (as it is not being used at all when viewing).

Let's hope "Gotham" solves this.

Cheers,
Fred
Growing old is inevitable. Growing up is optional!

rudig
Posts: 251
Joined: Tue Sep 06, 2011 6:21 pm

Re: Issues with ongoing (live) recordings and skip forward

Post by rudig » Fri Jan 03, 2014 9:52 pm

Using mediaportal and this issue is totally new for me.

cncb
Posts: 49
Joined: Sun Nov 13, 2011 12:31 am

Re: Issues with ongoing (live) recordings and skip forward

Post by cncb » Fri Mar 14, 2014 11:25 pm

Has anyone been able to try this with Gotham yet?

BlackBurn
Posts: 38
Joined: Tue Oct 02, 2012 4:19 pm
Location: Netherlands
Contact:

Re: Issues with ongoing (live) recordings and skip forward

Post by BlackBurn » Tue Mar 18, 2014 10:57 pm

Unfortunately I have no solution for this, but just want to let you know, you're not alone in this, I have exact the same problem!

Besides the problem described in the topic start, I also have another strange issue related to this problem.
When I have watched a program that's still being recorded, so e.g. I've started to watch a program 10 minutes after it has started it recording I can watch it, but not skip behind the 10 minutes. (as described above) However when the program is finished and I try to watch it, XBMC still tells me it is only 10 min. I can watch it and it plays for the full length, even over the 10 minutes, but I cannot skip behind the 10minutes, it will fall back then to a timestamp before the 10minutes.

To make it even more strange, I added the Windows share with the recordings to XBMC (Video - Files) and tried to start the recording from there and then it even says it is only 10min. long, no idea where XBMC stores this information.

If I start the recording with VLC or another player outside of XBMC, it shows the correct length of an hour.

My configuration;
Openelec 3.2.24
Argus 2.2.2

@Rudig, I've used Argus for a long time on Mediaportal till last week and Mediaportal doesn't has this issue.
If it is broke, fix it. If it ain't broke, make it better!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest