Has worked for years - suddenly no longer recording :(

In the unlikely ;) event you encounter a bug, tell us here
Posts: 9
Joined: Sat Feb 22, 2014 9:51 pm

Re: Has worked for years - suddenly no longer recording :(

Post by BogBeast » Thu May 18, 2017 5:04 pm


My original server is still active. I re-directed my recorder back to the original server and tried to schedule a recording on the recorder I know works..

Code: Select all

2017-05-18 15:37:41.1826 [Error][30]: System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it
   at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
   --- End of inner exception stack trace ---
   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar)
   --- End of inner exception stack trace ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at ArgusTV.Common.Recorders.Utility.RestProxyBase.<ExecuteRequestAsync>d__b.MoveNext()
2017-05-18 15:37:41.1826 [Warn ][LiveStreamAlive]: Failed to connect to recorder at '', error: One or more errors occurred.
2017-05-18 15:38:24.7193 [Warn ][Recordings Scheduler]: No free card found to record BBC NEWS HD - BBC News
I get a failure to connect message followed by a No free card found message.

I guess that the new VM proves it works, my problem is somewhere inside the database of the original server. I suspect it might be easier to completely uninstall everything from my server

And sorry Rudig, I did try your input but I didn't seem to get anywhere,,,

Posts: 251
Joined: Tue Sep 06, 2011 6:21 pm

Re: Has worked for years - suddenly no longer recording :(

Post by rudig » Thu May 18, 2017 7:52 pm

Try to solve first error first, the rest should be ignored. Argus cannot be reached therefore the rest of the errors is inaccurate.
Any firewalls in place that prevent acces? One test could be from vm to reach rest API through a browser

Posts: 96
Joined: Sat Feb 11, 2012 8:29 pm
Location: UK

Re: Has worked for years - suddenly no longer recording :(

Post by cybersheep » Mon May 22, 2017 5:39 pm

Thanks for the update. For the problems I was having, which may or may not be the same as your issue, I did a full uninstall, then deleted any files in the Argus directory in ProgramData that looked like they may be related to the recorder. After that I reinstalled Argus 2.3, rescanned and it found channels correctly, I linked the services to my channels, and it all started working again. I do still have one outstanding issue that BBC1 and BBC2 are not working for me, but that may be due to my possibly faulty LNB (mentioned in another thread) that I've as yet not got around to replacing.

Posts: 9
Joined: Sat Feb 22, 2014 9:51 pm

Re: Has worked for years - suddenly no longer recording :(

Post by BogBeast » Mon May 22, 2017 7:26 pm

I exported my scheduled recording into an XML and removed everything ArgusTV related from my server, including a complete de/re-install of SQL server

Once everything was hosed down I re-installed and added my already installed recorder back.

I had some issues with credentials. from the manual:

Code: Select all

"This brings you to the “Set Additional Services Settings” screen where you are requested to enter 
credentials to be used for remote HTTPS server access. You can choose to configure the core services 
with the default settings, or to manually. When you store your recordings on a different machine 
than this one, you need to select the manual configuration so that you can enter specific credentials 
for the core service, so that it can access the recordings share to read/write your recordings." 
I host recordings on a separate machine in, so was initially was using the 'manual configuration' just this would not work for me. I could not contact the scheduler service, so I tried again with default and it worked.

I was also haveing some issues with channels not appearing, I had to unlink everything in the recorder and relink and it all started appearing.

Re-imported by schedules and recordings and even managed to update my channel thumbs.

So everything seems to be working now.

Moral of the story: Wish I hadn't gone through the faffing and went straight to the re-install. I would suggest that anyone suffering similar issues go straight to a export > cleanse > re-install. Trying to debug is hopless... logs are too verbose and not really helpful.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests