EPG not showing. Probably config on my part

Full administration access to your ARGUS TV system
Post Reply
jegadeth
Posts: 3
Joined: Thu Jun 04, 2015 3:59 pm

EPG not showing. Probably config on my part

Post by jegadeth » Thu Jun 04, 2015 6:40 pm

Hello, I am new here. I have used WMC for a very long time to record my OTA. Since there's been no new development in years, I thought I would check out other softwares for doing this.

I currently am trying Kodi for my front end and have found Argus to be the most configurable for the back end, with a little deeper learning curve. I had tried MediaPortal and one other, but so far I like Argus the most.

My problem right now is I seem to have no EPG. I think I am doing something incorrectly, but I will upload a couple screenshots to show you. It did take me a bit to sort out the "services" and "channels". But enough FAQ searches educated me on that. The other PVR back ends I tried were able to grab the EPG without issue, as WMC has also done for the past couple years. But I really like the Argus software and want to get this working. Thanks for any help!!

Joe
Attachments
Channels.PNG
This lists my channel group with channels
Channels.PNG (35.36 KiB) Viewed 8728 times
Guide Channels.PNG
This shows there's no guide channel available to pick from the drop down
Guide Channels.PNG (31.92 KiB) Viewed 8728 times
EPG.PNG
This shows the blank EPG
EPG.PNG (37.16 KiB) Viewed 8728 times

Christoph21x
Posts: 1070
Joined: Wed Oct 19, 2011 9:39 am
Location: Berne / Switzerland

Re: EPG not showing. Probably config on my part

Post by Christoph21x » Fri Jun 05, 2015 10:48 am

Dear jegadeth

First of all: a warm Welcome to Argus TV & its forum!

I took your well elaborate question as an opportunity to make just a small update on our Wiki article, which was really of very low quality and far from even mentioning all methods.
It is still far from being a good article, but mentions some of the things, I would have posted as a first answer to your questions, here.
May I ask you to read our Wiki article http://www.argus-tv.com/wiki/index.php? ... G_Grabbing ?

Then we continue our exchange here?

Fyi: DVB-EPG is the easy way to get a very quick result, but quality usually is a bit lower and you can't select a preferred provider, as it always comes from the broadcasting station itself.
If you prefer XMLTV import, you need a third-party tool. There's a forums section treating this..: viewforum.php?f=70
As far as I see, very many use WebGrab+Plus (supporter thread in here: viewtopic.php?f=70&t=3919)

Please feel free to drop further questions, the start is indeed not self-explanatory...

Kind greetz - Chris
"One must still have chaos within oneself, to give birth to a dancing star." (F. Nietzsche)

jegadeth
Posts: 3
Joined: Thu Jun 04, 2015 3:59 pm

Re: EPG not showing. Probably config on my part

Post by jegadeth » Fri Jun 05, 2015 8:12 pm

So I think I have a beginners understanding to how it works. But I am unsure where the web address comes from to get my EPG data from. I live in the US - Central time. I grabbed the sample XML config file that was posted in that thread, but all the channels were in UK.

Then I saw in the instructions that it's just one of the .ini files but remove the .ini

(The website to be used to get the EPG from. The value entered here is the name of the .ini file that supplies the specific parameters for the site without .ini extension. e.g tvgids.nl.ini becomes site="tvgids.nl")

That was an excerpt from one of the XML files. Thank you again for any assistance.


Joe

Christoph21x
Posts: 1070
Joined: Wed Oct 19, 2011 9:39 am
Location: Berne / Switzerland

Re: EPG not showing. Probably config on my part

Post by Christoph21x » Fri Jun 05, 2015 10:27 pm

Hey Joe (always wanted to say this :) )

Looking at your stations, you're probably from around Wisconsin.
Forget about Webgrab+Plus - we don't have the right ini files to grab your EPG from the Web. Unless we create one by ourselves. I created a few, it's tremendous work.

So, if you agree, let's try to get closer to this topic by Q&A.
First: we need another grabber and/or the right source for your EPG.
Please help me googling "Wisconsin XMLTV grabber Win" - and try to judge the results for your region. Share your conclusion with me, please.

Please also read this thread "Best XMLTV Grabber for North America?" --> viewtopic.php?f=70&t=3923

Any potential light for you in these two sources, search & thread? Let me know..
Target shall be to establish a XMLTV grabber that creates the Guide.xml file for you with your preferred stations - then we copy it to the right directory, and: there it is.

Greetz from Switzerland - Chris

PS: Did you consider / try the DVB-EPG?
"One must still have chaos within oneself, to give birth to a dancing star." (F. Nietzsche)

Christoph21x
Posts: 1070
Joined: Wed Oct 19, 2011 9:39 am
Location: Berne / Switzerland

Re: EPG not showing. Probably config on my part

Post by Christoph21x » Fri Jun 05, 2015 11:52 pm

Grmpf.. found another source maybe interesting for you: http://www.argus-tv.com/wiki/index.php? ... G_Grabbers
"One must still have chaos within oneself, to give birth to a dancing star." (F. Nietzsche)

jegadeth
Posts: 3
Joined: Thu Jun 04, 2015 3:59 pm

Re: EPG not showing. Probably config on my part

Post by jegadeth » Sat Jun 06, 2015 1:13 am

I will check those out. I am currently trying the zap2xml program. I got it to function as far as logging in to download the guide from zap2it.com. But, the XML file is mostly blank. And my CMD window shows zero listings.

My XML file shows this:

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE tv SYSTEM "xmltv.dtd">

<tv source-info-url="http://tvlistings.zap2it.com/" source-info-name="zap2it.com" generator-info-name="zap2xml" generator-info-url="zap2xml@gmail.com">
</tv>


That's it. So I'll continue to try other options. My wife's yelling at me cause the bacon wrapped chicken breasts are burning on the grill....I guess I better go. Then crack another homebrew....and continue the grueling TV listing task.... :lol:

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests