Batch Processor

User avatar
PaulAEvans
Posts: 532
Joined: Tue Jul 01, 2008 11:42 am

Re: Batch Processor

Post by PaulAEvans » Fri Apr 19, 2013 1:25 pm

dot-i wrote:Cool! I'll put this most up-to-date code on GitHub then. Thanks!
Unfortunately on testing latest recompiled version, I have to report that it still does not function correctly. I have an existing simple batch set up to call on start of recording to output text file containing description.... however with no changes on my side the batchprocessor does not output any text file.

In addition there are no entries in the log of any batch activity. :cry: :cry:
Server: Gigabyte GA-Ex58-UD3R Intel i7 Corsair 6GB;Os on Sandisk 128GB SSD; TBS 6984 QuadDVB-S2, Nova-DT Dual DVB-T, Win7 SP1, Argus 2.3, SQLExp 2012
Clients: 3x XBMC RaspPi;1x ASUS A8N-VM CSM AMD 4200+ 2GB RAM, Win7 SP1 MP1.6/XBMC,Argus 2.3

User avatar
PaulAEvans
Posts: 532
Joined: Tue Jul 01, 2008 11:42 am

Re: Batch Processor

Post by PaulAEvans » Fri Apr 19, 2013 1:48 pm

I cannot code, but in an attempt to debug by looking at ArgusTV.Batch.ProcessCommand.exe.config I note it still has references to ForTheRecord.Batch
<?xml version="1.0"?>
<configuration>
<configSections>
<sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
<section name="ArgusTV.Batch.ProcessCommand.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
<section name="ForTheRecord.Batch.ProcessCommand.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
<section name="ForTheRecord.Testing.ProcessCommand.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
<section name="ForTheRecord.Testing.ProcessCommand.Settings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
</sectionGroup>
</configSections>
<startup><supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0,Profile=Client"/></startup><applicationSettings>
<ArgusTV.Batch.ProcessCommand.Properties.Settings>
<setting name="ArgusTVServerName" serializeAs="String">
<value>htpc</value>
</setting>
<setting name="ArgusTVPort" serializeAs="String">
<value>49942</value>
</setting>
</ArgusTV.Batch.ProcessCommand.Properties.Settings>
</applicationSettings>
</configuration>
Server: Gigabyte GA-Ex58-UD3R Intel i7 Corsair 6GB;Os on Sandisk 128GB SSD; TBS 6984 QuadDVB-S2, Nova-DT Dual DVB-T, Win7 SP1, Argus 2.3, SQLExp 2012
Clients: 3x XBMC RaspPi;1x ASUS A8N-VM CSM AMD 4200+ 2GB RAM, Win7 SP1 MP1.6/XBMC,Argus 2.3

User avatar
luetty
Posts: 535
Joined: Wed Nov 19, 2008 2:10 pm
Location: Germany/ Westerwald

Re: Batch Processor

Post by luetty » Fri Apr 19, 2013 6:27 pm

PaulAEvans wrote:
dot-i wrote:Cool! I'll put this most up-to-date code on GitHub then. Thanks!
Unfortunately on testing latest recompiled version, I have to report that it still does not function correctly. I have an existing simple batch set up to call on start of recording to output text file containing description.... however with no changes on my side the batchprocessor does not output any text file.

In addition there are no entries in the log of any batch activity. :cry: :cry:
+1 :oops:
Image

sunsetdk
Posts: 516
Joined: Thu May 29, 2008 4:19 am
Location: Denmark
Contact:

Re: Batch Processor

Post by sunsetdk » Fri Apr 19, 2013 9:02 pm

Hi

I hadnt checked-in the changes. So can you please update with the last changes.

User avatar
PaulAEvans
Posts: 532
Joined: Tue Jul 01, 2008 11:42 am

Re: Batch Processor

Post by PaulAEvans » Fri Apr 19, 2013 11:46 pm

sunsetdk wrote:Hi

I hadnt checked-in the changes. So can you please update with the last changes.
Sorry to jump the gun.. :? :?

I just downloaded your latest compilation and am happy to report initial tests look good. :D :D :D.

Thank you all so much for your time and effort. I will leave testing overnight and report back.

My tests so far show that batch processor is working and is reporting back correctly into MMC log
Server: Gigabyte GA-Ex58-UD3R Intel i7 Corsair 6GB;Os on Sandisk 128GB SSD; TBS 6984 QuadDVB-S2, Nova-DT Dual DVB-T, Win7 SP1, Argus 2.3, SQLExp 2012
Clients: 3x XBMC RaspPi;1x ASUS A8N-VM CSM AMD 4200+ 2GB RAM, Win7 SP1 MP1.6/XBMC,Argus 2.3

User avatar
luetty
Posts: 535
Joined: Wed Nov 19, 2008 2:10 pm
Location: Germany/ Westerwald

Re: Batch Processor

Post by luetty » Sat Apr 20, 2013 12:59 am

PaulAEvans wrote:
sunsetdk wrote:Hi

I hadnt checked-in the changes. So can you please update with the last changes.
Sorry to jump the gun.. :? :?

I just downloaded your latest compilation and am happy to report initial tests look good. :D :D :D.

Thank you all so much for your time and effort. ...
+1,+1,+1
Thank you, works perfect now!
Image

User avatar
dot-i
Site Admin
Posts: 5848
Joined: Mon Oct 01, 2012 3:40 pm

Re: Batch Processor

Post by dot-i » Sat Apr 20, 2013 8:41 am

In the mean time this latest code has now been put on the GitHub repository: https://github.com/ARGUS-TV/ARGUS-TV-Clients.

So if anyone makes further enhancements, please submit them as a pull request or patch :)
I have the heart of a child. I keep it in a jar on my shelf. -- Robert Bloch
Image

User avatar
PaulAEvans
Posts: 532
Joined: Tue Jul 01, 2008 11:42 am

Re: Batch Processor

Post by PaulAEvans » Sun Apr 21, 2013 11:33 pm

I can also confirm that following a weekend of recordings the updated batchprocessor is working fine. Once again many thanks to dot-i and sunsetdk for their great work. :D :D :D

As a final footnote could it be confirmed that this version of batchprocessor will function for the final ArgusTV release version. Other users may become dissuaded from upgrading if batchprocessor is not maintained for future releases.
Server: Gigabyte GA-Ex58-UD3R Intel i7 Corsair 6GB;Os on Sandisk 128GB SSD; TBS 6984 QuadDVB-S2, Nova-DT Dual DVB-T, Win7 SP1, Argus 2.3, SQLExp 2012
Clients: 3x XBMC RaspPi;1x ASUS A8N-VM CSM AMD 4200+ 2GB RAM, Win7 SP1 MP1.6/XBMC,Argus 2.3

User avatar
dot-i
Site Admin
Posts: 5848
Joined: Mon Oct 01, 2012 3:40 pm

Re: Batch Processor

Post by dot-i » Mon Apr 22, 2013 9:46 am

PaulAEvans wrote:As a final footnote could it be confirmed that this version of batchprocessor will function for the final ArgusTV release version. Other users may become dissuaded from upgrading if batchprocessor is not maintained for future releases.
Yes, this will work fine with the final 2.1 release.
I have the heart of a child. I keep it in a jar on my shelf. -- Robert Bloch
Image

jeffski10
Posts: 92
Joined: Sat Feb 28, 2009 2:03 pm

Re: Batch Processor

Post by jeffski10 » Sat Mar 08, 2014 4:29 pm

I'm using the Batch Processor to issue the Delete command with a 1 parameter to delete files. The files are all removed OK but I end up with empty folders - something that doesn't happen if I delete from the GUI. Is there a reason why this behaves differently?

Server: Windows 7, Argus recorder, Silicon Dust tuners
Clients: Openelec on a Pi and Gigabyte Brix

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest