ARGUS TV to Lights-Out for Windows / Windows Server

Christoph21x
Posts: 1070
Joined: Wed Oct 19, 2011 9:39 am
Location: Berne / Switzerland

Download post

Post by Christoph21x » Thu Jun 05, 2014 3:24 pm

Dear All

Just for your information: please find now latest news & downloads in the fist post of this thread (viewtopic.php?p=26681#p26681). This makes it easier for interested people to jump in.
The editing was done with the acceptance of jay.
Of course, correctiones will be announced here, not just in this 1st post ;)

Greetz - Chris
"One must still have chaos within oneself, to give birth to a dancing star." (F. Nietzsche)

jayrock
Posts: 147
Joined: Wed Apr 07, 2010 9:29 pm

Re: ARGUS TV to Lights-Out for Windows Server

Post by jayrock » Fri Jun 06, 2014 7:55 am

Thanks Chris,

actually I'm very happy to hand over to you and that you help to ensure the future support of ATV2LO!

Cheers,

jayrock

Christoph21x
Posts: 1070
Joined: Wed Oct 19, 2011 9:39 am
Location: Berne / Switzerland

Re: ARGUS TV to Lights-Out for Windows Server

Post by Christoph21x » Fri Jun 06, 2014 2:47 pm

dot-i wrote:Just curious, is the newly adjusted code using the new event system?

If not yet, take a look at the Scheduler Console's source code in the wip/2.3 branch on GitHub, in the Panel.cs file if I remember correctly - it's quite easy to hook in to the events :)
Hi dot-i
I don't find yet scheduler console at all in wip branch - if I'm wrong, maybe you might drop a direct link to the cs file, please?
Thanks & greetz - Chris

EDIT: FOUND it, excuse me.
"One must still have chaos within oneself, to give birth to a dancing star." (F. Nietzsche)

Christoph21x
Posts: 1070
Joined: Wed Oct 19, 2011 9:39 am
Location: Berne / Switzerland

Byebye FTR ...

Post by Christoph21x » Fri Jun 06, 2014 7:17 pm

EDIT: obsolete. Removed download.


... also in ATV2LO.

I decided to make a patch-over to naming conventions all away from "ftr" within ATV2LO independent from getting it back event-based.
Resaon: complexity. A change of names, including service executable, file & directory structure, variable names, dependencies incl. installer is not a small one. In fact, this means a kind of complete re-setup of a project. Unfortunately the user sees only log entries and maybe service executable name. :( dot-i can probably sing a song about it... :) (that's probably why jay didn't do it - lack of time - and I understand this perfectly: took me a couple of hours)

I didn't want this to be mixed up with the step of creating event-based hooks again as searching for errors then might be ... let's say slow :) (with me at least :D )

Is anyone willing to try this out? Please consider this as an ALPHA! Tested it here and it worked like the original, but you should really only try this "under control". But as Paul wished it... (ok, me too..). I will try to run it over the night here.. my own fault - I only learn, if it hurts :D ... and jay will probably kill me for this ;)

First uninstall the 3.0.0.8 version. Install then the new ATV2LO-Install.msi from within the wssx archive. And please test it and report back.
If something is failing, uninstall it again (that works properly) and re-install 3.0.0.8

Excuse me pls. if I misuse you as an alpha tester.. but it's needed in this case as I really nearly changed each & every file.

With this I will start looking at events, if you report back an impression.

With kind regards & greetz from WARM Switzerland - Chris

PS: no change to behaviour though - "can't connect" message still inherent.
"One must still have chaos within oneself, to give birth to a dancing star." (F. Nietzsche)

User avatar
PaulAEvans
Posts: 532
Joined: Tue Jul 01, 2008 11:42 am

Re: ARGUS TV to Lights-Out for Windows / Windows Server

Post by PaulAEvans » Fri Jun 06, 2014 7:38 pm

Chris I will look at this but I am not back home until late Tuesday so it will be Wednesday earliest. Thanks again for your continued efforts

Paul

Sent from my SM-T310 using Tapatalk
Server: Gigabyte GA-Ex58-UD3R Intel i7 Corsair 6GB;Os on Sandisk 128GB SSD; TBS 6984 QuadDVB-S2, Nova-DT Dual DVB-T, Win7 SP1, Argus 2.3, SQLExp 2012
Clients: 3x XBMC RaspPi;1x ASUS A8N-VM CSM AMD 4200+ 2GB RAM, Win7 SP1 MP1.6/XBMC,Argus 2.3

Christoph21x
Posts: 1070
Joined: Wed Oct 19, 2011 9:39 am
Location: Berne / Switzerland

Re: ARGUS TV to Lights-Out for Windows / Windows Server

Post by Christoph21x » Fri Jun 06, 2014 7:41 pm

PaulAEvans wrote:Chris I will look at this but I am not back home until late Tuesday so it will be Wednesday earliest. Thanks again for your continued efforts

Paul

Sent from my SM-T310 using Tapatalk
Dear Paul - no problem at all! I will start event development on this one now... also have not too much time the next days.
Thanks to YOU.. contributing always and fearless :)
Wish you some nice holidays...!
"One must still have chaos within oneself, to give birth to a dancing star." (F. Nietzsche)

User avatar
andrewNZ
Posts: 677
Joined: Thu Nov 26, 2009 2:07 pm
Location: Dunedin, New Zealand

Re: ARGUS TV to Lights-Out for Windows / Windows Server

Post by andrewNZ » Sat Jun 07, 2014 9:33 am

There appears to be an issue, at some point ATV2LO stops connecting to ARGUS TV. My system hadn't updated in @3 days. Restarting the service seemed to kick it off again.

Oddly, the error in the overview changed from "Cannot connect to Service (-3)" to "Cannot connect to Service (-2)" However there appears to be no sign of that second error in the logs.

Code: Select all

[INFO] [Ftr2LoService] 5/06/2014 7:12:12 a.m.:: Start service. Version 3.0.0.4
[DEBUG] [Ftr2LoService] 5/06/2014 7:12:12 a.m.:: No log files deleted.

[DEBUG] [Ftr2LoService] 5/06/2014 7:12:12 a.m.:: m_ftr2loThread started.

[DEBUG] [FTR2LO_Server] 5/06/2014 7:12:12 a.m.:: Inside FTR2LO_Server.

[DEBUG] [FTR2LO_Server] 5/06/2014 7:12:12 a.m.:: Internal Service Host started
[DEBUG] [FTR2LO_Server] 5/06/2014 7:12:12 a.m.:: Lights-Out Service status: Running
[DEBUG] [FTR2LO_Server] 5/06/2014 7:12:12 a.m.:: Argus TV Service status: Running
[INFO] [FTR2LO_Server] 5/06/2014 7:12:13 a.m.:: Setting refresh timer to 1 minutes.
[DEBUG] [FTR2LO] 5/06/2014 7:12:13 a.m.:: Trying to connect to Argus TV service on localhost:49943
[DEBUG] [FTR2LO] 5/06/2014 7:12:13 a.m.:: ServiceChannelFactories successfully initialized.
[DEBUG] [FTR2LO] 5/06/2014 7:12:13 a.m.:: ATV2LO local API version: 6
[DEBUG] [FTR2LO] 5/06/2014 7:12:33 a.m.:: Cannot connect to Service (-3)
[DEBUG] [FTR2LO] 5/06/2014 7:12:33 a.m.:: ftr2lo_main running...
[DEBUG] [FTR2LO] 5/06/2014 7:12:33 a.m.:: TaskList.xml found at C:\ProgramData\LightsOut\TaskList.xml
[DEBUG] [FTR2LO] 5/06/2014 7:12:33 a.m.:: Loading LightsOut task list ....
[DEBUG] [FTR2LO] 5/06/2014 7:12:33 a.m.:: ok.
[DEBUG] [FTR2LO] 5/06/2014 7:12:33 a.m.:: Fetching upcoming recordings ....
[DEBUG] [FTR2LO] 5/06/2014 7:12:34 a.m.:: Populating each upcoming recording ....
[DEBUG] [FTR2LO] 5/06/2014 7:12:34 a.m.:: Number of upcoming programs: 41
[DEBUG] [FTR2LO] 5/06/2014 7:12:34 a.m.:: Nothing to do.
[DEBUG] [FTR2LO] 5/06/2014 7:13:13 a.m.:: Periodic launch of ftr2lo_main...
[DEBUG] [FTR2LO] 5/06/2014 7:13:13 a.m.:: ftr2lo_main running...
[DEBUG] [FTR2LO] 5/06/2014 7:13:13 a.m.:: TaskList.xml found at C:\ProgramData\LightsOut\TaskList.xml
[DEBUG] [FTR2LO] 5/06/2014 7:13:13 a.m.:: Loading LightsOut task list ....
[DEBUG] [FTR2LO] 5/06/2014 7:13:13 a.m.:: ok.
[DEBUG] [FTR2LO] 5/06/2014 7:13:13 a.m.:: Fetching upcoming recordings ....
[DEBUG] [FTR2LO] 5/06/2014 7:14:13 a.m.:: Periodic launch of ftr2lo_main...
[DEBUG] [FTR2LO] 5/06/2014 7:14:13 a.m.:: ftr2lo_main running...
[DEBUG] [FTR2LO] 5/06/2014 7:14:13 a.m.:: TaskList.xml found at C:\ProgramData\LightsOut\TaskList.xml
[DEBUG] [FTR2LO] 5/06/2014 7:14:13 a.m.:: Loading LightsOut task list ....
[DEBUG] [FTR2LO] 5/06/2014 7:14:13 a.m.:: ok.
[DEBUG] [FTR2LO] 5/06/2014 7:14:13 a.m.:: Fetching upcoming recordings ....
[DEBUG] [FTR2LO] 5/06/2014 7:14:14 a.m.:: Populating each upcoming recording ....
[DEBUG] [FTR2LO] 5/06/2014 7:14:14 a.m.:: Number of upcoming programs: 41
[DEBUG] [FTR2LO] 5/06/2014 7:14:14 a.m.:: Nothing to do.
[DEBUG] [FTR2LO] 5/06/2014 7:14:14 a.m.:: Populating each upcoming recording ....
[DEBUG] [FTR2LO] 5/06/2014 7:14:15 a.m.:: Number of upcoming programs: 41
[DEBUG] [FTR2LO] 5/06/2014 7:14:15 a.m.:: Nothing to do.
[DEBUG] [FTR2LO] 5/06/2014 7:15:13 a.m.:: Periodic launch of ftr2lo_main...
[DEBUG] [FTR2LO] 5/06/2014 7:15:13 a.m.:: ftr2lo_main running...
[DEBUG] [FTR2LO] 5/06/2014 7:15:13 a.m.:: TaskList.xml found at C:\ProgramData\LightsOut\TaskList.xml
[DEBUG] [FTR2LO] 5/06/2014 7:15:13 a.m.:: Loading LightsOut task list ....
[DEBUG] [FTR2LO] 5/06/2014 7:15:13 a.m.:: ok.
[DEBUG] [FTR2LO] 5/06/2014 7:15:13 a.m.:: Fetching upcoming recordings ....
[DEBUG] [FTR2LO] 5/06/2014 7:15:13 a.m.:: Populating each upcoming recording ....
[DEBUG] [FTR2LO] 5/06/2014 7:15:13 a.m.:: Number of upcoming programs: 41
[DEBUG] [FTR2LO] 5/06/2014 7:15:13 a.m.:: Nothing to do.
[DEBUG] [FTR2LO] 5/06/2014 7:16:13 a.m.:: Periodic launch of ftr2lo_main...
[DEBUG] [FTR2LO] 5/06/2014 7:16:13 a.m.:: ftr2lo_main running...
[DEBUG] [FTR2LO] 5/06/2014 7:16:13 a.m.:: TaskList.xml found at C:\ProgramData\LightsOut\TaskList.xml
[DEBUG] [FTR2LO] 5/06/2014 7:16:13 a.m.:: Loading LightsOut task list ....
[DEBUG] [FTR2LO] 5/06/2014 7:16:13 a.m.:: ok.
[DEBUG] [FTR2LO] 5/06/2014 7:16:13 a.m.:: Fetching upcoming recordings ....
[DEBUG] [FTR2LO] 5/06/2014 7:16:13 a.m.:: Populating each upcoming recording ....
[DEBUG] [FTR2LO] 5/06/2014 7:16:13 a.m.:: Number of upcoming programs: 41
[DEBUG] [FTR2LO] 5/06/2014 7:16:13 a.m.:: Nothing to do.
[DEBUG] [FTR2LO] 5/06/2014 7:17:13 a.m.:: Periodic launch of ftr2lo_main...
[DEBUG] [FTR2LO] 5/06/2014 7:17:13 a.m.:: ftr2lo_main running...
[DEBUG] [FTR2LO] 5/06/2014 7:17:13 a.m.:: TaskList.xml found at C:\ProgramData\LightsOut\TaskList.xml
[DEBUG] [FTR2LO] 5/06/2014 7:17:13 a.m.:: Loading LightsOut task list ....
[DEBUG] [FTR2LO] 5/06/2014 7:17:13 a.m.:: ok.
[DEBUG] [FTR2LO] 5/06/2014 7:17:13 a.m.:: Fetching upcoming recordings ....
[DEBUG] [FTR2LO] 5/06/2014 7:18:13 a.m.:: Periodic launch of ftr2lo_main...
[DEBUG] [FTR2LO] 5/06/2014 7:18:13 a.m.:: ftr2lo_main running...
[DEBUG] [FTR2LO] 5/06/2014 7:18:13 a.m.:: TaskList.xml found at C:\ProgramData\LightsOut\TaskList.xml
[DEBUG] [FTR2LO] 5/06/2014 7:18:13 a.m.:: Loading LightsOut task list ....
[DEBUG] [FTR2LO] 5/06/2014 7:18:13 a.m.:: ok.
[DEBUG] [FTR2LO] 5/06/2014 7:18:13 a.m.:: Fetching upcoming recordings ....
[DEBUG] [FTR2LO] 5/06/2014 7:19:13 a.m.:: Periodic launch of ftr2lo_main...
[DEBUG] [FTR2LO] 5/06/2014 7:19:13 a.m.:: ftr2lo_main running...
[DEBUG] [FTR2LO] 5/06/2014 7:19:13 a.m.:: TaskList.xml found at C:\ProgramData\LightsOut\TaskList.xml
There are another two and a half days of logs, but they just continue on the same from there.

Edit: Note that these logs were from the patch version (NOT the latest). I have now installed the latest, and I'll check again soon. I expect it to display the same behaviour.

Also, the version 3.0.0.9 installer said the install failed, but the install did succeed.
You can fix it, or you can fix it until it's broken. I usually choose the latter.

Server: WHS 2011. Hauppauge HVR 2200. Avermedia A835. ArgusTV Server. EPG Collector.
Clients: Win7 64bit. MediaPortal. ArgusTV Client. StreamedMP.

Christoph21x
Posts: 1070
Joined: Wed Oct 19, 2011 9:39 am
Location: Berne / Switzerland

Re: ARGUS TV to Lights-Out for Windows / Windows Server

Post by Christoph21x » Sat Jun 07, 2014 9:53 am

Hi Andrew - thanks for this report! Sorry that there was no update on your schedule.
A workaround may be to add Atv2LoService to the list of services to be stopped and restarted in your LO Config for the time being.

You´ll hear from me... thx & greetz
"One must still have chaos within oneself, to give birth to a dancing star." (F. Nietzsche)

Christoph21x
Posts: 1070
Joined: Wed Oct 19, 2011 9:39 am
Location: Berne / Switzerland

Re: ARGUS TV to Lights-Out for Windows / Windows Server

Post by Christoph21x » Sat Jun 07, 2014 10:05 am

Could you give me some details on those two issues?

- Failure on install 3.0.0.9: your´re running WHS as far as I remember, er? (Then it could be a versioning issue - can´t test this here :( ).
And what was the content of the error message?
- Disconnection: everything else was running ok with Argus after those 3 days? (I guess so)
"One must still have chaos within oneself, to give birth to a dancing star." (F. Nietzsche)

User avatar
andrewNZ
Posts: 677
Joined: Thu Nov 26, 2009 2:07 pm
Location: Dunedin, New Zealand

Re: ARGUS TV to Lights-Out for Windows / Windows Server

Post by andrewNZ » Sat Jun 07, 2014 2:22 pm

Hi Chris. It's not a disaster the calendar wasn't updated. I had a manual uptime window set still too.

Failure to install, appears to be a failure to register it as an addin in the dashboard. ATV2LO does install, and is present in the dashboard, but doesn't appear in the list of addins as it normally would.
Capture.PNG
Capture.PNG (13.95 KiB) Viewed 7323 times

For the (assumed) disconnection. Yes everything was running normally. As you can see by the logs, it doesn't seem to be acting in a predictable manner at all.


Another issue has cropped up too. I see an error any time I change ATV2LO settings in the dashboard
I got this one the first time:
Capture2.PNG
Capture2.PNG (12.39 KiB) Viewed 7323 times
Then I get this one every time after:
Capture3.PNG
Capture3.PNG (13.58 KiB) Viewed 7323 times
You can fix it, or you can fix it until it's broken. I usually choose the latter.

Server: WHS 2011. Hauppauge HVR 2200. Avermedia A835. ArgusTV Server. EPG Collector.
Clients: Win7 64bit. MediaPortal. ArgusTV Client. StreamedMP.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest